getting started
45 TopicsHow to Get Started in the Community
Welcome to the Human Connection community! Follow these simple steps to get started... Read the Community How-to Guides Read the Community Guidelines Read the Community Best Practices Once you feel ready, come and introduce yourself to the rest of the community.1KViews2likes0CommentsCommunity Navigation Guide
This community was built to foster connections between you, our passionate customers, and us, the experts who are building the products that you love. To get started; read the Community Guidelines, introduce yourself to the rest of the community and take a look around.411Views18likes0CommentsFIN7 Threat Hunting with Splunk: Ep.3 – Execution Logs
I am pulling my hair with this last question Rebuild the PowerShell script from the previous question using the three parts found in the PowerShell operational logs. What is the MD5 hash of this file? (The file should not contain any trailing white space or return characters) I ran index=* (EventCode=4104) | search "stager.ps1" AND "scriptblock" | table _raw and added the script content of files (1 of 3) (2 of 3) (3 of 3) to a new file. I removed the spaces and made sure they are glued together. I pasted the file in cyber chef with md5 selected and I keep getting the wrong hash. See a sample of the beginning and end of the 3 files This is just a sample below. I really don't know what else to do with this. $EncodedCompressedFile = @' 7b1pk+LKcjD83RH3P5y4cT/Y0ddusfXAfcMRT5U2JJCgBBJIDn8AAQIklmmgBfz6N7O00sCcnuuxH9vPUcRMo1qycqvMrFItfxmsgu3keHqf//avv/2fP//pH/5NiiJts9+9H//xz+H8fTuPatV/mUXRn//p u3rgE9+I/KPY62u+qTQuvp0Xqu3KPkEovj/867/++Z/+9A9/+oe/jFZbY7757V9/w1+96fpvf3NW78fTJCJRtPP/UfjrvxmT4/Lf//Y3Y3L+x79ML8f54V+6821wXP5VOFcEQfgn+FuDv/CnLnCY/za4HI7zzb9Yp+1xtZn/i7Y9zt93+8H8/WPlQ3Vj8n5YTiKAKe72lxToX4W/prj89aaVHEuOm/g+nxznwyX8mQFuRR38ja3//w== '@ $Decoded = [System.Convert]::FromBase64String($EncodedCompressedFile) $MemStream = New-Object System.IO.MemoryStream $MemStream.Write($Decoded, 0, $Decoded.Length) $MemStream.Seek(0,0) | Out-Null $CompressedStream = New-Object System.IO.Compression.DeflateStream($MemStream, [System.IO.Compression.CompressionMode]::Decompress) $StreamReader = New-Object System.IO.StreamReader($CompressedStream) $Output = $StreamReader.readtoend() $Output | IEXSolved392Views0likes1Comment💻🔐 Study Group Vote Revealed! Get Involved! 💻🔐
The Votes are In! This week you asked for a defensive lab for Study Group. What are we studying? This week, we've selected Web Server Logs: Ep.6 — The Tomcat's Out Of The Bagin which it'll be your job to investigate an incident by looking at web server log files. How can I get involved? Dive into the lab: Get started on the lab and challenge yourself to complete it by the end of the week. Join the discussion: Don’t forget to share your experiences, ask questions, and drop any tips or tricks you’ve picked up along the way in this forum discussion. Support each other: This is all about collaboration—whether you’re struggling with a concept or want to share an "aha" moment, jump into the conversation! We’ll re-vote on Friday for next week’s lab, so stay engaged and help shape where this study group goes. Let’s learn together and level up our skills! Every community member who has access to an Immersive license is welcome to join this study group. I'd also like to welcome our new members from last week: jaureguibooksit cmc15 sargentv pepplebryan jp4821a SCepparulo RBlv shahedanara lking2547 Yuknow312 WinChan rob_nolan ohheykhanh ChristopherRouse_80 zooooomer Benjamin LP megangrace oP 4n6cy Joeatt75 Cicada3301 Leslie_Saravia_OHD kpas1868 x0du Garyb aloharae egly443 Sam Thomas0akes Djparker SElder markbaluis07 It's great to have you here! If you're looking for a place to start in this community, partaking in Study Group is the place for you!319Views0likes1CommentHow to use Immersive cyber ranges for cyber threat research?
Want to know how to take advantage of the cyber ranges platform to do malware and adversary research in a sandboxed environment? In this post, I’ll walk you through how to get access to the Heimdall Detection Engineering template for CTI so you can do just that! The Heimdall template is a domain-joined range that contains workstations, a domain controller, and security tooling that you’d ordinarily find in a real network. The purpose of this template is to enable cyber threat research, where you can launch attacks and malware, capture indicators of compromise through tools like Velociraptor, a SIEM network packet capture tool, and some analyst workstations with a bunch of analysis and reverse engineering tools. With that said, let’s get started. Firstly, you’ll need to go to the cyber ranges sign-up page and sign up with a name and email address. After hitting “Sign up”, you’ll need to go to your email and find the confirmation email to get your credentials, then go back to the cyber ranges website and log in with your new credentials. After signing in, you’ll be in the main ranges dashboard. You’ll need to connect your own Amazon Web Services (AWS) account to use ranges, as provisioning machines will cost money for every hour that they are active or stored. Once you’ve connected your AWS account, you can then go to “Range Templates” and launch the Heimdall range.312Views3likes1CommentHow do I join the community?
I want to contribute to the community, how can I register and participate?Solved284Views0likes1CommentStrangeness with SSO?
Hey, Is anyone else having weird issues with authentication when trying to be logged into both the main Immersive Labs platform, and this Community site in the same browser at the same time? If I load the Community site first, it mostly seems to play nice. But if I've got IL open in another tab, and come here, it seems to get stuck in weird authentication loops, where I log in, stick my creds in (for customer/EU), then get redirected back to the site to find it is still saying "Sign In" in the top right corner. I also could just see a load of discussions about one of the FIN7 labs when I wasn't logged in - but now that I'm logged in, I can't find the thread at all. Perhaps I should stop using MS Edge? ;-p Cheers, Steve.Solved272Views2likes7Comments