immersive labs
199 TopicsOT Threat Actors - CyberAv3ngers
Hi, I’m stuck at Q6 “During the defacement campaign of Unitronics, the threat actor exploited internet-facing PLCs and HMIs. What MITRE ATTEMPT&CK tactic does this fall under?” it seems obvious to me but wasn’t working and none of the “Initial Access Techniques” worked. Thanks for any help...8Views0likes0CommentsStruggling to find the IT email on Simulations: BarterTown Delivery
During the last few days, I’ve been stuck on this lab, and I’m not sure what I’m missing. The lab asks us to use OSINT tools and techniques to gather intelligence about individuals to target within the organization, with the goal of testing the awareness of BarterTown’s IT staff and eventually gaining a foothold in the internal network. I’ve been using the information provided by the lab as a starting point for my reconnaissance. The website gives us several employees and their email addresses, but none of them are identified as IT staff. I also found the DNS SOA contact (hostmaster.bartertown.bitnet), but that appears to be a standard administrative DNS alias rather than an actual employee. The mail server does not seem to allow useful anonymous user enumeration, and the other reconnaissance results have not revealed the missing user. Has anyone completed this lab and can give me a hint about where/how the missing target information is supposed to be discovered?24Views0likes0CommentsBrute Force task in an 15 min lab taking over 30 hours to complete
Hello everyone, I am doing an Immersive Labs about hacking, and there is a lab where I can learn how to crack codes with Hydra using SSH, HTTP, and FTP. The problem is that for the FTP part, I am supposed to brute-force a password (a 4-character password composed of lowercase letters and numbers). I am using the correct command, but the brute force is extremely slow, doing roughly 1 attempt every 3.5 seconds, which brings the total cracking time to over 30 hours. I waited 2 hours already, which is far too long, especially since the lab has to be extended every 10–15 minutes. However, now it has become personal, and I really want to get this password. Can anyone help? I am using the following command: hydra -l jimmy -x 4:4:1a -f -t 64 ftp://(ip address) i have tried -t, 4, 8 and 16, doesn't change anything I also tried creating 4 lists containing all possible passwords and running them in parallel with -P instead of using -x, but I always got too many attempts. Name of the lab ist: Credential Access: Using Hydra48Views0likes1CommentDFIR CTF: LightNeuron DLL - Question 8
In relation towards finding the decrypted email. I am wondering about what I am getting wrong from the conditional breakpoint in order to expose all the decrypted strings after the return function After searching up the XOR key location I went to from Ghidra Through the RET function which I thought would expose the strings I ran going to the ret function then after following the process in order to go to the DLL malware and got into the ret function I set the breakpoint and debug restarted However, it kept saying memory address unavailable. such as this also includes setting the CF flag to 0 I am wondering about what I am doing wrong here and where should I dig deeper? Note: used Gemini to help look into possible solutions however, refered to https://www.youtube.com/watch?v=Tc8Wl37uwYc for aid44Views0likes1CommentHelp with Cross Site Request Forgery (Twooter)
Hi folks, I'm having a hard time getting past the Cross Site Request Forgery lab - specifically I'm not sure what sort of payload I can use to obtain the username of the scraper. I can get their IP address using just a link and I've tried a range of scripts hosted on my machine which I then link to in my 'twoots' but there's no connection at all. I'd be really grateful for any direction as to the sort of payload that could capture the necessary information. Thanks, JonathanSolved471Views0likes6CommentsMicrosoft Sentinel SOAR: Demonstrate Your Skills
I am currently working on the Microsoft Sentinel SOAR lab, which involves the use of logic app for automation. From task 4 of the lab, which requires me to do the below and the lab will automatically detect when I complete the task but this hasn't been marking it as complete for me; Has anyone experienced similar issue because I am certain my logic app designer is correct and the run history has been successful ? Attached are screenshots522Views0likes19CommentsImmersive Labs- Create a detection rule - Google SecOps
a { text-decoration: none; color: #464feb; } tr th, tr td { border: 1px solid #e6e6e6; } tr th { background-color: #f5f5f5; } Hello everyone, I hope you can help me. I am currently taking the "Google SecOps Fundamentals: Demonstrate Your Skills" course, and I am stuck on Task 12, where I need to create a detection rule. I have already created the rule, but the lab is not recognizing it or marking the task as completed. The instructions say that I need to create a rule that detects communication with one of the specified domains. I have configured the following rule, but I'm not sure if it is correct. I am not very experienced with Chronicle/Google SecOps, so I am having trouble understanding what I might be missing. Does anyone know what could be wrong or what additional configuration is required for the task to be validated? Any guidance would be greatly appreciated. Thank you! This is the rule I created: rule lumma_c2_iocs { meta: author = "Diana Quezadas" description = "Detect DNS queries to known Lumma C2 IOC domain." severity = "HIGH" events: $e.metadata.event_type = "NETWORK_DNS" $ioc_url = $e.network.dns.questions.name re.regex( $ioc_url, `(?i)^forbidstow\.site$` ) outcome: $domain = array_distinct($ioc_url) $risk_score = 85 condition: $e }50Views0likes1Comment